v5 SSO clients experiencing issue connecting to system
Incident Report for Examity
Postmortem

Issue Summary & Root Cause
On the evening of Monday, October 9, Examity's support team received reports from clients stating that the SSO connections were not working. After investigating the issue, Examity discovered that a core certificate had expired. To resolve the problem, the Engineering and IT teams regenerated the expired certificate and redeployed the necessary services. It was determined that all related services needed to be redeployed as well in order to inherit the new certificate.

Timeline

Corrective & Preventive Measures

Examity uses robust cloud provider certificate management services to proactively monitor and manage the certificates. The certificate in the context of this incident was missing in configuration. Examity has updated the configuration to ensure proactive measures are taken going forward to avoid such incidents.

Examity has updated the process document after certificate renewal to restart related services.

Posted Oct 11, 2023 - 09:04 EDT

Resolved
This incident is resolved completely.
Posted Oct 10, 2023 - 07:34 EDT
Monitoring
The issue is fixed. We are monitoring the results.
Posted Oct 10, 2023 - 03:24 EDT
Update
We are continuing to investigate the issue.
Posted Oct 10, 2023 - 02:18 EDT
Update
We are continuing to investigate the issue.
Posted Oct 10, 2023 - 01:10 EDT
Update
We are continuing to investigating the issue,
Posted Oct 10, 2023 - 00:08 EDT
Update
We are continuing to investigating the issue,
Posted Oct 09, 2023 - 23:02 EDT
Update
We are continuing to investigate the issue.
Posted Oct 09, 2023 - 22:06 EDT
Update
We are continuing to investigating the issue
Posted Oct 09, 2023 - 21:32 EDT
Investigating
Based on results we have resumed investigation.
Posted Oct 09, 2023 - 21:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2023 - 19:55 EDT
Identified
The issue has been identified and we are working on implementing a fix.
Posted Oct 09, 2023 - 19:41 EDT
Investigating
We are currently investigating the issue
Posted Oct 09, 2023 - 19:18 EDT
This incident affected: Examity API (Examity Client API).